Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Error compiling for board Arduino Leonardo
09-04-2017, 12:18 AM (This post was last modified: 09-04-2017 12:19 AM by RicSo.)
Post: #1
Error compiling for board Arduino Leonardo
Hello there!

I bought a partial kit, since I had a bunch of the parts already, including a few arduino Leonardo "compatible" boards.

I build the robot and when I try to upload the code to my board I get the error message I used as the subject. I've tried with the latest version of the Arduino IDE as well as with a previous version (1.6.13) but I get exactly the same error.

I've attached a text file with the verbose output from the compiler and below is a link for the board I am using.

https://www.amazon.com/gp/product/B071P7...UTF8&psc=1

Your prompt help will be greatly appreciated. You must imagine the anxiety of finishing the build and not being able to use the robot! :-P

Thanks in advance and best regards.


Attached File(s)
.txt  iBoardBot compiler error_ricso.txt (Size: 26.78 KB / Downloads: 2)
Find all posts by this user
Quote this message in a reply
09-04-2017, 10:34 AM
Post: #2
RE: Error compiling for board Arduino Leonardo
You should not have any problems compiling the code. Is that the case?
You only get the error message once you are uploading the code to the board?

From the verbose .txt: looks like there is a conflict with the libraries:
Multiple libraries were found for "EEPROM.h"
Used: C:\Users\souzar2\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.20\li​braries\EEPROM
Not used: C:\Users\souzar2\Documents\Arduino\libraries\arduino-NVM
Using library EEPROM at version 2.0 in folder: C:\Users\souzar2\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.20\li​braries\EEPROM

Try to download the Arduino IDE (Windows ZIP file for non admin install) just in case there is a problem with permissions/libraries.: https://www.arduino.cc/download_handler....indows.zip
Visit this user's website Find all posts by this user
Quote this message in a reply
09-04-2017, 12:13 PM
Post: #3
RE: Error compiling for board Arduino Leonardo
Thank you for the quick reply!

I am not having problems uploading the code, as I don't eve get to that point. I am having problems compiling the code.

The conflict with the EEPROM libraries does not stop the compiler. It seems like the problem is with "avr-gcc-ar", because that where the compiler fails.

The IDE I am using is exactly the one you sent me the link to.


(09-04-2017 10:34 AM)jpedroc Wrote:  You should not have any problems compiling the code. Is that the case?
You only get the error message once you are uploading the code to the board?

From the verbose .txt: looks like there is a conflict with the libraries:
Multiple libraries were found for "EEPROM.h"
Used: C:\Users\souzar2\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.20\li​braries\EEPROM
Not used: C:\Users\souzar2\Documents\Arduino\libraries\arduino-NVM
Using library EEPROM at version 2.0 in folder: C:\Users\souzar2\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.20\li​braries\EEPROM

Try to download the Arduino IDE (Windows ZIP file for non admin install) just in case there is a problem with permissions/libraries.: https://www.arduino.cc/download_handler....indows.zip
Find all posts by this user
Quote this message in a reply
09-05-2017, 06:25 PM
Post: #4
RE: Error compiling for board Arduino Leonardo
PROBLEM almost SOLVED!!

I moved to another PC and was able to compile and upload the code to my Leonardo.

Everything seems to work rather well, except an erratic behavior exhibited by the Eraser Servo. It seems to extend out gradually as the carriage moves up the board and, by doing so, it allows the marker to continue touching the board, drawing horizontal lines as it tries to erase what was previously on the board.

T the top of the board, the eraser is fully extended and, only then, begins to erase the board appropriately.

Since I used servos that I already had, they did not come "calibrated" and I didn't see any calibration info on the assembly instructions.

Can anyone help me out here?

Thanks in advance.



(09-04-2017 12:13 PM)RicSo Wrote:  Thank you for the quick reply!

I am not having problems uploading the code, as I don't eve get to that point. I am having problems compiling the code.

The conflict with the EEPROM libraries does not stop the compiler. It seems like the problem is with "avr-gcc-ar", because that where the compiler fails.

The IDE I am using is exactly the one you sent me the link to.


(09-04-2017 10:34 AM)jpedroc Wrote:  You should not have any problems compiling the code. Is that the case?
You only get the error message once you are uploading the code to the board?

From the verbose .txt: looks like there is a conflict with the libraries:
Multiple libraries were found for "EEPROM.h"
Used: C:\Users\souzar2\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.20\li​braries\EEPROM
Not used: C:\Users\souzar2\Documents\Arduino\libraries\arduino-NVM
Using library EEPROM at version 2.0 in folder: C:\Users\souzar2\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.20\li​braries\EEPROM

Try to download the Arduino IDE (Windows ZIP file for non admin install) just in case there is a problem with permissions/libraries.: https://www.arduino.cc/download_handler....indows.zip
Find all posts by this user
Quote this message in a reply
09-05-2017, 08:14 PM
Post: #5
RE: Error compiling for board Arduino Leonardo
Hi!
Good to know you solved the Arduino IDE issue ;-)

Regarding the eraser: take a look to the TROUBLESHOOTING at the very end of this page: https://www.jjrobots.com/iboardbot-assem...tructions/
There is info about how to set the servos
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)