Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How patch the USB driver in eggbot extension of Inkscape
08-06-2016, 08:07 PM
Post: #1
How patch the USB driver in eggbot extension of Inkscape
If Eggbot Extension of Inkscape give crazy communication errors when you try plotting , something is wrong in serial driver config.

I spent a long time to find a solution making a puzzle from partial information from Google search.
At the end I solved the problem in this way:

1) Download Utraedit from http://www.ultraedit.com/downloads/ultra...nload.html and install it.

2) Connect USB and open Arduino IDE

3) Open TOOLS - SERIAL MONITOR and set "BOTH NL&CR"

4) Type "v" (small v for Version) : If it answer "EBBv13_and_above Protocol emulated by Eggduino-Firmware V1.6a", means that the connection is OK and the problem is in Inkscape driver

5) Open TOOLS - GET BOARD INFO and write somewhere the VID: ???? and PID: ???? numbers you read.

6) Search in C:\Program Files\Inkscape\share\extensions the file eggbot_scanwin32.py and open it with ULTRAEDIT

7) Modify row 6 in eggbot_scanwin32.py with your right VID and PID value and save.

Now Inkscape will plot on your egg!!!
Find all posts by this user
Quote this message in a reply
11-02-2016, 10:05 PM (This post was last modified: 11-02-2016 10:42 PM by jpedroc.)
Post: #2
RE: How patch the USB driver in eggbot extension of Inkscape
Will there be an answer to the problem? I managed to upload the software to the bot, but inkscape does not recognize it. I am using mac 10.11. There is no file eggbot_scanwin32.py but a eggbot_scanlinux.py.

But no way to enter the VID or PID (I know how to use vi, but I don't know how to program python).
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)