Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Unable to connect arduino leonardo
12-06-2015, 04:43 PM
Post: #1
Unable to connect arduino leonardo
Hi,

I didn't succeed to connect my both arduino leonardo using USB and Windows 8.1 x64 or Windows 10 x64.
In the Device Manager, I see "Périphérique USB inconnu (Echec de la demande de descripteur de périphérique)

I tried to install without success Arduino drivers from C:\Program Files (x86)\Arduino\drivers\arduin.inf or C:\Program Files (x86)\Arduino\drivers\FTDI USB Drivers.
Of course I used unsigned drivers installation process.
http://www.makeuseof.com/tag/how-can-i-i...windows-8/

Do you have a idea and a tutorial for this issue ?
Find all posts by this user
Quote this message in a reply
12-07-2015, 02:44 PM (This post was last modified: 12-07-2015 02:45 PM by JohnQ.)
Post: #2
RE: Unable to connect arduino leonardo
(12-06-2015 04:43 PM)cho934 Wrote:  Hi,

I didn't succeed to connect my both arduino leonardo using USB and Windows 8.1 x64 or Windows 10 x64.
In the Device Manager, I see "Périphérique USB inconnu (Echec de la demande de descripteur de périphérique)

I tried to install without success Arduino drivers from C:\Program Files (x86)\Arduino\drivers\arduin.inf or C:\Program Files (x86)\Arduino\drivers\FTDI USB Drivers.
Of course I used unsigned drivers installation process.
http://www.makeuseof.com/tag/how-can-i-i...windows-8/

Do you have a idea and a tutorial for this issue ?
If you bought the B-robot kit, the Arduino Leonardo is already programmed. You can use your Brobot just after assembling it. I did not have problems under windows 8, so sorry, can not help you further Blush
Are you using the right version of the Arduino IDE? It comes with the latest drivers.
Find all posts by this user
Quote this message in a reply
12-08-2015, 05:06 PM
Post: #3
RE: Unable to connect arduino leonardo
(12-07-2015 02:44 PM)JohnQ Wrote:  
(12-06-2015 04:43 PM)cho934 Wrote:  Hi,

I didn't succeed to connect my both arduino leonardo using USB and Windows 8.1 x64 or Windows 10 x64.
In the Device Manager, I see "Périphérique USB inconnu (Echec de la demande de descripteur de périphérique)

I tried to install without success Arduino drivers from C:\Program Files (x86)\Arduino\drivers\arduin.inf or C:\Program Files (x86)\Arduino\drivers\FTDI USB Drivers.
Of course I used unsigned drivers installation process.
http://www.makeuseof.com/tag/how-can-i-i...windows-8/

Do you have a idea and a tutorial for this issue ?
If you bought the B-robot kit, the Arduino Leonardo is already programmed. You can use your Brobot just after assembling it. I did not have problems under windows 8, so sorry, can not help you further Blush
Are you using the right version of the Arduino IDE? It comes with the latest drivers.

Yes I tested the last one (1.6.6) and older (1.0.5).

It works like a charm using other Arduino Mega, but not using Leonardo (the both I received)... I don't understand myself.

I'm going on to fix my windows issue and I will test it this week also under Ubuntu. And I will give you the results.
Find all posts by this user
Quote this message in a reply
12-09-2015, 09:32 AM
Post: #4
RE: Unable to connect arduino leonardo
(12-08-2015 05:06 PM)cho934 Wrote:  
(12-07-2015 02:44 PM)JohnQ Wrote:  
(12-06-2015 04:43 PM)cho934 Wrote:  Hi,

I didn't succeed to connect my both arduino leonardo using USB and Windows 8.1 x64 or Windows 10 x64.
In the Device Manager, I see "Périphérique USB inconnu (Echec de la demande de descripteur de périphérique)

I tried to install without success Arduino drivers from C:\Program Files (x86)\Arduino\drivers\arduin.inf or C:\Program Files (x86)\Arduino\drivers\FTDI USB Drivers.
Of course I used unsigned drivers installation process.
http://www.makeuseof.com/tag/how-can-i-i...windows-8/

Do you have a idea and a tutorial for this issue ?
If you bought the B-robot kit, the Arduino Leonardo is already programmed. You can use your Brobot just after assembling it. I did not have problems under windows 8, so sorry, can not help you further Blush
Are you using the right version of the Arduino IDE? It comes with the latest drivers.

Yes I tested the last one (1.6.6) and older (1.0.5).

It works like a charm using other Arduino Mega, but not using Leonardo (the both I received)... I don't understand myself.

I'm going on to fix my windows issue and I will test it this week also under Ubuntu. And I will give you the results.
Just in case, try 1.6.5 version. That is the used version in the jjrobot webpage....
Find all posts by this user
Quote this message in a reply
12-09-2015, 10:23 PM
Post: #5
RE: Unable to connect arduino leonardo
It seems to be related to Windows 8.1/10 and USB3... and specifically to the ATMEGA32U4 (so leonardo and micro).

"unknow device" every time, even if the arduino.inf or genuino.inf are installed correctly...

And no pb for others arduino like MEGA, duemilanove, ...
Find all posts by this user
Quote this message in a reply
12-10-2015, 02:22 PM
Post: #6
RE: Unable to connect arduino leonardo
(12-09-2015 10:23 PM)cho934 Wrote:  It seems to be related to Windows 8.1/10 and USB3... and specifically to the ATMEGA32U4 (so leonardo and micro).

"unknow device" every time, even if the arduino.inf or genuino.inf are installed correctly...

And no pb for others arduino like MEGA, duemilanove, ...

Have you tried this?:
http://www.makeuseof.com/tag/how-can-i-i...windows-8/
or
http://kierendavies.blogspot.co.uk/2012/...-with.html
Find all posts by this user
Quote this message in a reply
12-11-2015, 04:04 PM
Post: #7
RE: Unable to connect arduino leonardo
Yes, as I said in my first message. I tested older and last drivers. Moreover last drivers from Arduino are now signed correctly. So installation of the .inf can be installed successfully, but still unrecognised in the device manager...
I'm waiting also an answer from Arduino.

Who use it with Windows 8.1 (or 10) and USB3 ? could you send the driver version used and how is it recognized (screenshots of the device manager and of the properties ?)

(12-10-2015 02:22 PM)JohnQ Wrote:  
(12-09-2015 10:23 PM)cho934 Wrote:  It seems to be related to Windows 8.1/10 and USB3... and specifically to the ATMEGA32U4 (so leonardo and micro).

"unknow device" every time, even if the arduino.inf or genuino.inf are installed correctly...

And no pb for others arduino like MEGA, duemilanove, ...

Have you tried this?:
http://www.makeuseof.com/tag/how-can-i-i...windows-8/
or
http://kierendavies.blogspot.co.uk/2012/...-with.html
Find all posts by this user
Quote this message in a reply
12-12-2015, 11:37 AM
Post: #8
RE: Unable to connect arduino leonardo
Finally it's working now. I just changed the microUSB cable !
The provided blue microUSB cable sent in the kit doesn't work. I received 2 kits, and the second cable is working perfectly.

Tested with Arduino software 1.6.6 and the last signed drivers.
So now, I'm able to change the configured Wifi IP address Cool

Thank you for help.


(12-11-2015 04:04 PM)cho934 Wrote:  Yes, as I said in my first message. I tested older and last drivers. Moreover last drivers from Arduino are now signed correctly. So installation of the .inf can be installed successfully, but still unrecognised in the device manager...
I'm waiting also an answer from Arduino.

Who use it with Windows 8.1 (or 10) and USB3 ? could you send the driver version used and how is it recognized (screenshots of the device manager and of the properties ?)

(12-10-2015 02:22 PM)JohnQ Wrote:  
(12-09-2015 10:23 PM)cho934 Wrote:  It seems to be related to Windows 8.1/10 and USB3... and specifically to the ATMEGA32U4 (so leonardo and micro).

"unknow device" every time, even if the arduino.inf or genuino.inf are installed correctly...

And no pb for others arduino like MEGA, duemilanove, ...

Have you tried this?:
http://www.makeuseof.com/tag/how-can-i-i...windows-8/
or
http://kierendavies.blogspot.co.uk/2012/...-with.html
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)