Post Reply 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem with pen up/down servo (rest works, almost)
04-26-2020, 01:17 PM
Post: #1
Problem with pen up/down servo (rest works, almost)
after missing eastern already ,-) I finally got all the parts and electronics together today. Everything seems to work okay, however the pen servo does NOT, unfortunately.

My environment
  • Arduino IDE 1.8.12
  • "EBBv13_and_above Protocol emulated by Eggduino-Firmware V1.6a"
  • Inkscape 0.92.4 with eggbot addin as portable version provided from jjrobots
  • Windows 10/x64
  • The board is connected via USB and provided via COM4

I compiled the arduino project and uploaded successfully, run Inkscape "as Admin" and went to the eggbot setup page in the addin. The stepper motors seem wot work well, they are moving without any glitch, motor on/off, all works for this part.

The pen servo does however not really work, I noticed the following things
  • When clicking on the "apply" Button in the setup dialog to test up/down limits the servo moves very slightly into one direction but not the other. However, increasing the "up" position, it moves again on "apply" clicking and again not on the other.
  • Changing the numbers in any way does not change the outcome.
  • Holding the servo on my ear I can notice very low noise like scratching, so it looks like it tries to move but however does not.
  • However, printing something works okay in respect to the two servos, this just looks perfect - however without pen movement

I tried various things, without success:
  • Double checked connection orientation
  • Used port 2 instead of 1 (by modifying macro "#define servoPin 3") - exactly the same behaviour
  • Completely removed the servo from the frame just to make sure no machanical impact is there.

I am now a little dazzled what to do. I searched this forum already but was not successfull to find any working hint for my problem, although other people seem to had servo related problems as well.

One thing that I also noticed: I opened the serial monitor in the IDE and tried various commands like "v", "TB" and so one. I did not get any response...? That is completely strange as I was able to upload the software and get it running via Inkscape. My setting is 960 baud.

So, any ideas are highly welcome, thanks!
Find all posts by this user
Quote this message in a reply
05-24-2020, 10:36 AM
Post: #2
RE: Problem with pen up/down servo (rest works, almost)
Just for the records of this forum: I was able to fix the problem, however quite strange solution: By debugging the code with pen up/down functionality I found out that the values send from the Inkscape plugin do not match with value ranges of the arduino code. Furthermore up/down values seem do be turned wrong i.e. up is used for down position and vice versa. As I used stock software as recommende from jjrobots I doubt the current recommended setup does work at all...?

After applying the following code change, all worked well for me. File "Functions", function "stepperModeConfigure", please note the change in calculation of the penDownPos and penUpPos variables:

            case 4:
        penDownPos = (int)((float)value/240 - 25);
            case 5:
        penUpPos = (int)((float)value/240 - 25);

Have fun, stay healthy,
Find all posts by this user
Quote this message in a reply
05-25-2020, 09:02 AM
Post: #3
RE: Problem with pen up/down servo (rest works, almost)
Hey... I had the same problem but it got solved just using the Portable version of the Inkscape. Even so, I will give it a try and check if your solution can fix the original problem. Thanks for this!
Find all posts by this user
Quote this message in a reply
Post Reply 

Forum Jump:

User(s) browsing this thread: 1 Guest(s)