Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
New portable version of the latest Inkscape software - connection problems
02-24-2020, 09:08 PM
Post: #1
New portable version of the latest Inkscape software - connection problems
Till now I was working with the following setup for my sphere-o-bot:

- Inkscape 0.91 (running as admin)
- Eggbot Plug-In 2.4.0
- Eggduino-Firmware V1.6a (latest version from jjrobots.com)
- COM2

Today I tried to use your new portable version of the Inkscape software. But I can't get this version working (the old setup still works) - Failed to connect to EggBot. Sad

How can I solve the problem?


Attached File(s) Thumbnail(s)
   
Find all posts by this user
Quote this message in a reply
02-24-2020, 09:51 PM
Post: #2
RE: New portable version of the latest Inkscape software - connection problems
Are you using the DEVIA control board?
So, the portable version does not work for you, but the old one does? Is there any other App keeping the COM port open?
Visit this user's website Find all posts by this user
Quote this message in a reply
02-25-2020, 06:00 AM (This post was last modified: 02-25-2020 06:00 AM by hami.)
Post: #3
RE: New portable version of the latest Inkscape software - connection problems
(02-24-2020 09:51 PM)JJrobots JP Wrote:  Are you using the DEVIA control board?
So, the portable version does not work for you, but the old one does? Is there any other App keeping the COM port open?

Yes, I'm using the DEVIA control board. The old version works, the portable version not. I've also tried it on two different computers, still the same. I don't think that there is a problem with the COM port because the old version works.
Find all posts by this user
Quote this message in a reply
02-25-2020, 11:11 AM (This post was last modified: 02-25-2020 02:05 PM by JJrobots JP.)
Post: #4
RE: New portable version of the latest Inkscape software - connection problems
(02-25-2020 06:00 AM)hami Wrote:  
(02-24-2020 09:51 PM)JJrobots JP Wrote:  Are you using the DEVIA control board?
So, the portable version does not work for you, but the old one does? Is there any other App keeping the COM port open?

Yes, I'm using the DEVIA control board. The old version works, the portable version not. I've also tried it on two different computers, still the same. I don't think that there is a problem with the COM port because the old version works.
Hmmm...
Are you launching the INKSCAPE.EXE file as Admin? This should do the trick. We have tested the Portable version in, at least, 12 different Windows OS systems (no previous Inkscape installations) and it worked on every system. Check that "RUN AS ADMIN" thing
Visit this user's website Find all posts by this user
Quote this message in a reply
02-25-2020, 07:11 PM
Post: #5
RE: New portable version of the latest Inkscape software - connection problems
(02-25-2020 11:11 AM)JJrobots JP Wrote:  
(02-25-2020 06:00 AM)hami Wrote:  
(02-24-2020 09:51 PM)JJrobots JP Wrote:  Are you using the DEVIA control board?
So, the portable version does not work for you, but the old one does? Is there any other App keeping the COM port open?

Yes, I'm using the DEVIA control board. The old version works, the portable version not. I've also tried it on two different computers, still the same. I don't think that there is a problem with the COM port because the old version works.
Hmmm...
Are you launching the INKSCAPE.EXE file as Admin? This should do the trick. We have tested the Portable version in, at least, 12 different Windows OS systems (no previous Inkscape installations) and it worked on every system. Check that "RUN AS ADMIN" thing

Yes, I'm launching the INKSCAPE.EXE as admin. Tried now also a third Windows computer. This machine is without previous Inkscape installation. And also no success. All computers are running Windows 10. Maybe the firmware installed on the DEVIA board should be updated to a newer version?


Attached File(s) Thumbnail(s)
   
Find all posts by this user
Quote this message in a reply
02-26-2020, 02:42 PM
Post: #6
RE: New portable version of the latest Inkscape software - connection problems
There has to be something we are missing here.
1) You are using the latest Sphere-o-bot Arduino code as we can see from your screencapture (and a DEVIA control board)
2) Your sphere-o-bot works (at least with the 0.91 version of the Inkscape) so the hardware is fine.
3) And even with a third computer with Windows 10 the new Inkscape portable version can not move it.

Honestly, we do not know what the problem could be... We have been testing the portable version on many computers and none of them caused problems.
Could you confirm you are using this portable version please?: https://www.jjrobots.com/wp-content/uplo...-o-bot.zip
Visit this user's website Find all posts by this user
Quote this message in a reply
02-26-2020, 08:20 PM
Post: #7
RE: New portable version of the latest Inkscape software - connection problems
(02-26-2020 02:42 PM)JJrobots JP Wrote:  There has to be something we are missing here.
1) You are using the latest Sphere-o-bot Arduino code as we can see from your screencapture (and a DEVIA control board)
2) Your sphere-o-bot works (at least with the 0.91 version of the Inkscape) so the hardware is fine.
3) And even with a third computer with Windows 10 the new Inkscape portable version can not move it.

Honestly, we do not know what the problem could be... We have been testing the portable version on many computers and none of them caused problems.
Could you confirm you are using this portable version please?: https://www.jjrobots.com/wp-content/uplo...-o-bot.zip

Hello,

same result with this version :-(
Find all posts by this user
Quote this message in a reply
02-27-2020, 09:18 AM
Post: #8
RE: New portable version of the latest Inkscape software - connection problems
(02-26-2020 08:20 PM)hami Wrote:  
(02-26-2020 02:42 PM)JJrobots JP Wrote:  There has to be something we are missing here.
1) You are using the latest Sphere-o-bot Arduino code as we can see from your screencapture (and a DEVIA control board)
2) Your sphere-o-bot works (at least with the 0.91 version of the Inkscape) so the hardware is fine.
3) And even with a third computer with Windows 10 the new Inkscape portable version can not move it.

Honestly, we do not know what the problem could be... We have been testing the portable version on many computers and none of them caused problems.
Could you confirm you are using this portable version please?: https://www.jjrobots.com/wp-content/uplo...-o-bot.zip

Hello,

same result with this version :-(
Could you move back to the 0.91 version? We will try to find what it going on here in the meantime
Visit this user's website Find all posts by this user
Quote this message in a reply
02-27-2020, 09:44 AM (This post was last modified: 02-27-2020 09:47 AM by maddin-la.)
Post: #9
RE: New portable version of the latest Inkscape software - connection problems
Maybe you can try to use an other USB cable.

I loaded up with Arduino successfully and used the portable version without any problems. I find this the easiest way.

BUT: I removed an old Inkscape version including "Inkscape" folder in Programs folder first.
Find all posts by this user
Quote this message in a reply
02-27-2020, 07:25 PM (This post was last modified: 02-28-2020 01:59 PM by hami.)
Post: #10
RE: New portable version of the latest Inkscape software - connection problems
Hello,

I tried two other USB-cables but without success. But then I tried to install the latest driver from the Arduino IDE package instead of the Windows standard driver - and
now it works :-)
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)