Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
B-Robot does not work - Stepper motors whine
12-15-2019, 07:39 PM
Post: #11
Wink RE: B-Robot does not work - Stepper motors whine
Hello JJrobots JP,
Thank you for updating the connection diagram.
Now my robot is working as expected. Big Grin

best regards
Patrick
Find all posts by this user
Quote this message in a reply
12-15-2019, 08:53 PM
Post: #12
RE: B-Robot does not work - Stepper motors whine
(12-15-2019 07:39 PM)KnightBot Wrote:  Hello JJrobots JP,
Thank you for updating the connection diagram.
Now my robot is working as expected. Big Grin

best regards
Patrick

No, thank you for the heads up :-)
Visit this user's website Find all posts by this user
Quote this message in a reply
12-20-2019, 02:02 PM (This post was last modified: 12-20-2019 02:05 PM by maxmar.)
Post: #13
RE: B-Robot does not work - Stepper motors whine
(12-11-2019 03:03 PM)JJrobots JP Wrote:  Hi Max, Patrick
Thanks for the text. You are completely right. The assembly guide was misleading (video and image). The problem comes from the latests Arduino code. We changed the motor orientation by mistake when testing new PID parameters and left the code like that. Confused
We just updated the GUIDE with this new connecting diagram:

About your points:
1) Thanks again. Guide updated
2) The stepper motors allows you to connect the cables in two positions, depending on which one, the motor will spin in one or the other direction. So... If you connect the cables "backwards" and at the same time, swap the motors (RIGHT-LEFT) The brobot will be able to keep it balance but the control will be just the opposite (FORWARD<-> BACK / RIGHT <-> LEFT) Regarding the noise: that is strange. For the motor, it does not really matter wich direction to spin. Please check the cable has enough slack so the headers are not forced and making proper contact?

3) You mean that the control of the stepper motor from the DEVIA is not so smooth like just using an Arduino (UNO?) and an A4988? or that the output voltage of the A4988 jumps when they are placed in the DEVIA? if we are in the second case, was the USB port connected while you were testing it?


About 2):
The cables of both motors have some slack, this should not be a problem. Still, I also tried with another cable (length = 1m) from another NEMA17 motor. Surprisingly, the robot does not work anymore with this cable. The behavior is as described at the very beginning. Not able to stand up, when trying to help it stand, it falls over immediately, and both motors scream and whine again. I also unplugged and plugged the cable on both ends again, no change.
My guess is that the voltage drop over the long cable might be too high.
Additionally, when I lift the robot from the ground, both wheels start to spin at high speed, even when trying to hold it horizontally, it does not stop. If I tilt it far enough to one side, the rotation eventually changes direction. Is this normal?
When I put it back on the ground, the motors seem not to be able to cope with the sudden change in torque load. The robot does not keep its balance and falls over pretty immediately, the motors whine and scream like when wrongly connected. Any suggestions there or is this normal?


About 3):
I am using the Arduino Uno Rev 3 board, the setup for testing the A4988 motor driver is shown in the attached picture. It tallies with the setup sketched at step 2 on https://www.instructables.com/id/Drive-a...-a-A4988-/.
In this setup, the output voltage of the A4988 driver's voltage (measured at the potentiometer to ground) can be adjusted smoothly by the potentiometer. When the driver is mounted on the Devia control board, the voltage can only be adjusted from 0 V to 1.1 V, when rotating further, nothing happens until there is the jump to 2 V (as described in my previous post). I conclude that something is wrong with the voltage provided by the Devia control board. In other words and to answer the question, it seems to me that the Devia control board (at least the piece I own) in combination with the motor driver is somewhat inferior and buggy compared to the Arduino board.
The USB cable was not connected to the Devia control board, when measuring. I tried the Arduino in both configurations, powered by USB only and powered by the AC/DC power supply only. The behavior is exactly the same, smooth and continuous adjustment of the voltage is possible.


About the smartphone app and the PID controller:
Does anyone know why the angle values are so strange on my phone? Or why there is no information about the battery status?
Moreover, I tried to change the constants of the PID controller. When I change anything, just the slightest deviation from the default value of 0.5 for any of the four constants, the robot goes completely crazy. Accelerating like hell, falling over, crashing into the next best obstacle, sometimes changing spinning direction of the motors. I do not know what happens there. Anyone seen the same behavior and ideas on how to solve this issue?


Merry Christmas and best regards,
Max


Attached File(s) Thumbnail(s)
   
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)