Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Manual mode doesn't work. Robot doesn't move
11-14-2019, 02:36 PM
Post: #1
Manual mode doesn't work. Robot doesn't move
I've built my AirhockeyRobot. But it doesn't work. The Computer Vision is working, and the serial monitor if the Leonardo shows the incoming Coordinates, but still the Motors don't move.

I tried the simplest mode, the Manual mode in the App, and there the same issue. I see the incoming coordinates, but the motors dont move.
The motors are active, means you cant turn them freely, and the robot even can move when it is initialized. So the connection between the Leonardo and the Motors is ok.

Any idea to resolve the problem?


Heres a fragment of my serial monitor:
P2 111,82
P2 111,105
P2 116,129
P2 125,158
P2 144,180
P2 157,192
P2 162,200
P2 152,219
P2 138,232
P2 126,235
P2 118,237
P2 112,238
Find all posts by this user
Quote this message in a reply
11-15-2019, 08:42 AM
Post: #2
RE: Manual mode doesn't work. Robot doesn't move
Looks like the stepper motor drivers are not doing their job? Could you upload photos of your set-up? Are the stepper motor drivers placed correctly? Cables ok? Try unplugging one stepper motor (just in case one is damaged and shortcircuiting the board) and try to move just one motor
Visit this user's website Find all posts by this user
Quote this message in a reply
11-15-2019, 01:24 PM (This post was last modified: 11-15-2019 01:24 PM by FelixKunzJr.)
Post: #3
RE: Manual mode doesn't work. Robot doesn't move
(11-15-2019 08:42 AM)JJrobots JP Wrote:  Looks like the stepper motor drivers are not doing their job? Could you upload photos of your set-up? Are the stepper motor drivers placed correctly? Cables ok? Try unplugging one stepper motor (just in case one is damaged and shortcircuiting the board) and try to move just one motor

I'm fairly sure, the Stepper-Driver work. I've tried to pull the Step-Pin to low, and the motor made the step, as expected. I also measured the Output of the arduino, where i should see the Impulses, but i couldn't detect any. So i think the arduino doesn't send the Stepping signal, for some reason.
Find all posts by this user
Quote this message in a reply
11-16-2019, 07:25 PM
Post: #4
RE: Manual mode doesn't work. Robot doesn't move
I have to ask, but... Are you sure the smartphone is connected to the Air hockey Robot? It looks like it is not receiving any control command from the mobile
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)