Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Ineffective self-righting
06-27-2019, 11:08 PM
Post: #1
Ineffective self-righting
Everything seems good with the little chap - he balances and responds to the app commands, however, when he falls over, the arm can't get him back up.

It swings down in the right direction, but seemingly not far enough, fast enough or strong enough to set him balancing again.

I've tried extending the arm to give a bit more leverage and I've made the 'hand' wider to stand him up more, neither of which help.

I've tried both sets of servo pins and two new MG90S servos.

I don't know whether this is relevant, but when I switch him on, and he calibrates, then twitches a bit, I have to stand him up very quickly to get him to balance. Otherwise the steppers just whine noisily until I lay him down again. Lay him down, pick him up, turn him over, repeat - eventually he gets the idea and balances. Is that normal?

And if it's not, might that be contributing to his ineffective self-righting?
Find all posts by this user
Quote this message in a reply
06-28-2019, 09:32 PM
Post: #2
RE: Ineffective self-righting
It looks like a power supply with not enough voltage problem. Are you using alkaline batteries?
The whine noise from the motors lead me to the same conclusion: weak batteries. But I might be wrong: did you try to adjust the power delivered by the stepper motor driver adjusting the A4988 "screw"? more info here: https://www.jjrobots.com/b-robot-evo-2-assembly-guide/ (My robot falls due to...)
Visit this user's website Find all posts by this user
Quote this message in a reply
06-28-2019, 10:10 PM
Post: #3
RE: Ineffective self-righting
Aha!

The comment about the trimmers did the trick. The trimmers on the stepper driver boards that I got from you can rotate all the way round forever and with my old eyes it's pretty difficult to say where max and min are - I can't see a flat on the rotor and I don't know whether the base is at the top, bottom or either side (so even if I could see a flat, I couldn't align it).

So I beefed up the voltage by connecting a 12v wall wart direct and then turned the trimmers clockwise a little from where they were. Bingo!

Thanks for the pointers.

Rather than chewing through dozens of Duracells, I was using Eneloop NiMhs and at 1.2v fully charged, they don't deliver the ooomph.

I'll experiment a bit with some 2s and 3s lipos.


Thanks again.


Andy
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)