Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Step motors don't work
12-27-2018, 05:14 PM
Post: #5
RE: Step motors don't work
(12-27-2018 02:33 PM)JJrobots JP Wrote:  
(12-26-2018 07:06 PM)AnAwesomeNoob Wrote:  
(12-26-2018 06:34 PM)JJrobots JP Wrote:  
(12-26-2018 06:10 PM)AnAwesomeNoob Wrote:  Hi,

I have successfully uploaded the program to the robot and am also able to connect my phone to it. The servo is able to move and be controlled, and I can see the tilt of the robot on my phone. I am unable to control the motors via my phone and the program as well. I have gone through the video again to check if the wiring is correct. Still doesn't work Sad. What do I have to do to solve this problem?

It looks like a problem with the stepper motors? The MPU is working as it is sending angle values back to the smartphone...
Can you upload some photos of your setup?


I have updated the post to show the pictures.
Everything looks fine. Does the robot keep the balance? The only problem is that you can not control it from the smartphone? Which one are you using iOS or Android? If Android, which version?

The motors don’t turn even with the program. I only tried to use the phone (an iPhone) to make sure it wasn’t a problem with the program
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
Step motors don't work - AnAwesomeNoob - 12-26-2018, 06:10 PM
RE: Step motors don't work - JJrobots JP - 12-26-2018, 06:34 PM
RE: Step motors don't work - AnAwesomeNoob - 12-26-2018, 07:06 PM
RE: Step motors don't work - JJrobots JP - 12-27-2018, 02:33 PM
RE: Step motors don't work - AnAwesomeNoob - 12-27-2018 05:14 PM
RE: Step motors don't work - AnAwesomeNoob - 12-30-2018, 11:38 PM
RE: Step motors don't work - JJrobots JP - 01-02-2019, 11:06 AM

Forum Jump:


User(s) browsing this thread: 1 Guest(s)