Post Reply 
 
Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Brobot wont balance
05-03-2017, 10:24 AM
Post: #11
RE: Brobot wont balance
(05-03-2017 07:10 AM)taprik Wrote:  It's my first time with jjrobots. It's not my first time with arduino project.

I guess you've tried many things... What I've read in the error you got is that there is a problem with something related to the MPU6050.

The process of debugging I use with arduino is a step by step one. In your case I will try to isolate the arduino + MPU6050, then arduino + MPU6050 + battery and adds things and find when and where it stops working.

On your posts you don't tell us how you build it : what shield you use, .... On your movie I see something that seems to be a regulator. Why do you need that ?

best

well,,if i disconnect the battery and let the arduino use the 5v from the usb,,i dont see any errors( MPU6050 Error:2 3 4 -11) with the 2.6v (the motors are not working,,only mpu and arduino)

when i connect the battery(9v),,after the 10-15 sec callibration it gives me these 4 errors

the caps at Vmot are 220uf,,can that be a problem?
Find all posts by this user
Quote this message in a reply
05-03-2017, 12:15 PM
Post: #12
RE: Brobot wont balance
Congrats with your build !

but

With this kind of build you have many subjects of trouble :
- connections
- power crossing data
- steel construction
- many screw connections

the brain shield by jjrobots shop is 28 €. It's compact and reliable...

Nevertheless :
I will try to disconnect arduino + MPU(your shield) + battery from your build and see what's going on.

my advice is : make a start (something that works), had piece by piece, ... and see when and where it stops working

good luck
Find all posts by this user
Quote this message in a reply
05-03-2017, 05:37 PM
Post: #13
RE: Brobot wont balance
(05-03-2017 12:15 PM)taprik Wrote:  Congrats with your build !

but

With this kind of build you have many subjects of trouble :
- connections
- power crossing data
- steel construction
- many screw connections

the brain shield by jjrobots shop is 28 €. It's compact and reliable...

Nevertheless :
I will try to disconnect arduino + MPU(your shield) + battery from your build and see what's going on.

my advice is : make a start (something that works), had piece by piece, ... and see when and where it stops working

good luck
ITS WORKING!!!!!!!!

taprik
you made me look piece by piece the board and found the problem!!


thx allot!!

1st.. the board and the construction of the body is very good,
2nd..The problem was that the mpu was in the wrong position.
3rd..If you look at the schematic,there's 4x100nf caps at the 5v and 3.3v rail to ground,,when i made the PCB i didn't include them cuz ,why use small caps at power rails if you already have 4x10uf at the regulators,,that was the mistake.

Small capacitors handle noise and fast transients!!!!!

soldering them at the back of the pcb and all good

here's a video,,,sorry for the position of the camera

Thank you JJrobots!!

https://www.youtube.com/watch?v=M5gXOayp...e=youtu.be
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)