Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
B-Robot does not turn on
05-06-2019, 12:53 AM
Post: #5
RE: B-Robot does not turn on
(05-01-2019 09:57 PM)JJrobots JP Wrote:  
(05-01-2019 04:35 AM)argonaut Wrote:  
(04-30-2019 09:25 AM)JJrobots JP Wrote:  
(04-30-2019 03:53 AM)argonaut Wrote:  Hi,

I have finished uploading my code and putting my robot together. When I however turn it on, nothing happens.

I turn the robot on, I place it on its front (or back). It doesn't do anything. I also don't see the wifi of the robot. I have taken it apart and placed it back together with no luck. The robot is wired according to the video.

What am I missing?
Could you upload photos of your set-up? Did you get any error when uploading the code? Would you do this:
- Disconnect everything (motors,stepper motor drivers and servo). Just leave the MPU connected and turn the B.robot ON. Check if you can see the B-robot WIFI Network. If so, that means the problem is related with the SERVO (short-circuit?), A4988 modules (is the heatsink touching the metal headers?)

Here is a picture of my setup before disconnecting everything but the MPU while turned on.

[Image: IMG-20190430-212423.jpg]

I disconnected everything outside of the MPU still and nothing. I tried to read serial data from the IDE and the arduino didn't connect and cannot find a serial port to connec to.

I then try to connect to the arduino with the brain shield disconnected and I immediately get a found serial port for the leonardo. Unfortunately it doesn't work with the arduino connected to the shield so I can't read the MPU data.

Its odd and not sure whats the issue is. I have a second brain shield I was planning to use on another project. I can give it a go tomorrow and see if the results are any different.

Unplug the stepper motor drivers too. It looks like there is a short-circuit somewhere and the Arduino can not boot up by itself.

Thanks for the photo. I can not appreciate if all the cables are properly connected but the polarities look fine.

The Brain shield has an internal diode to protects itself against short circuits so everything should be fine as long as we find it. ;-)

I disconnected everything, and tried to see the Arduino again. No port showed up.

I connected my other brain shield and can see an open com port and wifi, and got the robot to work without issue. I think the other brain board is dead unfortunately.
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
B-Robot does not turn on - argonaut - 04-30-2019, 03:53 AM
RE: B-Robot does not turn on - JJrobots JP - 04-30-2019, 09:25 AM
RE: B-Robot does not turn on - argonaut - 05-01-2019, 04:35 AM
RE: B-Robot does not turn on - JJrobots JP - 05-01-2019, 09:57 PM
RE: B-Robot does not turn on - argonaut - 05-06-2019 12:53 AM

Forum Jump:


User(s) browsing this thread: 1 Guest(s)