Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
software not working on mac
04-26-2018, 04:06 PM
Post: #5
RE: software not working on mac
(04-23-2018 05:19 PM)JJrobots JP Wrote:  
(04-20-2018 05:32 PM)WayneG Wrote:  Hi,

I have successfully loaded and have running Inkscape .91 and EggBot 2.7.1 on my Mac. I had to make the following change to the ebb_serial.py code for the Sphere-o-bot to be recognized.

if comports:
comPortsList = list(comports())
EBBport = None
for port in comPortsList:
if port[1].startswith("Arduino Leonardo"): //<<<--- Change made here.
EBBport = port[0] #Success; EBB found by name match.
break #stop searching-- we are done.
if EBBport is None:
for port in comPortsList:
if port[2].startswith("USB VID:PID=04D8:FD92"):
EBBport = port[0] #Success; EBB found by VID/PID match.
break #stop searching-- we are done.
return EBBport

Regards,

Wayne

PS: I was unable to load on the Mac the version of EggBot (2.4) suggested by the documentation.

Thank you for this! Do you mind if we link this post to a updated assembly guide for MAC users? What Mac OS are you currently using?

No I don't mind you making the link.

I am using Mac OS High Sierra (10.13).
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
software not working on mac - colin_barlow - 03-03-2018, 06:15 PM
RE: software not working on mac - WayneG - 04-20-2018, 05:32 PM
RE: software not working on mac - WayneG - 04-26-2018 04:06 PM
RE: software not working on mac - Majdi - 04-07-2019, 05:12 AM
RE: software not working on mac - AZgang - 04-08-2019, 12:02 AM
RE: software not working on mac - serin_i - 04-08-2019, 07:12 PM
RE: software not working on mac - Majdi - 04-09-2019, 04:58 PM
RE: software not working on mac - serin_i - 04-12-2019, 06:07 PM

Forum Jump:


User(s) browsing this thread: 1 Guest(s)