Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
BRobot Oscillation then fall over
06-22-2017, 04:58 PM (This post was last modified: 06-22-2017 05:00 PM by Bondo.)
Post: #1
BRobot Oscillation then fall over
Completed my B Robot yesterday, but it is having trouble staying upright. Although not a kit, I bought the stepper motors, brain shield and stepper drivers from JJRobots, and it is built according to the instructions on the site. It is almost identical to the kit, using the same hardware although I do not have a servo fitted yet. However ... it refuses to stay upright. It goes through the calibration stage and all seems well. But then when I try to stand it up, the robot oscillates forwards and backwards. It will stay upright for a short time (occasionally) but any attempt to move it either by pushing gently or using the wifi app will result in it rocking wildly then falling over.

I have been through all the relevant threads on this forum, and tried moving the gyro to the top of the bot, but this made no difference. Also ran through some of the debug code, and there was one error, but I don't know what it means. Here is some of the pertinent output:


OK
MAC:5CCF7FACE0BD

AT+CWQAP

QAP fail

ERROR
!Timeout!
AT+CWMODE=2


Does anyone know what this error means and why it was generated?

I have posted a video of this erratic behaviour:

https://youtu.be/lgKP8SFiRL8

Perhaps I need to make some adjustments to the parameters in the code? Or is the hardware causing this error? I really don't know, so would appreciate some guidance from the more experienced members of the forum.
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
BRobot Oscillation then fall over - Bondo - 06-22-2017 04:58 PM

Forum Jump:


User(s) browsing this thread: 1 Guest(s)