Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Having problems detecting the Arduino?: Checking things
04-14-2017, 01:40 AM
Post: #3
RE: Having problems detecting the Arduino?: Checking things
Okay,

I made some progress (I think) but still not working. I realized I didn't install Eggduio correctly so I grabbed the latest git repo and gave it a try. The code would not compile. I did some googling and needed to make the following changes to the code:
  • In Helper_Function.ino I replaced all instances of "void inline" with "inline void"
  • In Helper_Function.ino I commented out the line //SPMCSR &= ~SELFPRGEN;
These modifications allowed the code to compile in Arduino IDE 1.8.2. Uploading seemed to be successful.

I tried the SM,2000,0,-200 command (with carriage return) and got an "ok" signal but no change in either motor. I also tried running Inskape (With my serial port modification from my previous post). I no longer get the "Failed to connect to EggBot. :(" (Yeah!!) However, Now I don't get any messages. Everything on the Inkscape side seems good but the motors are not doing anything. If I try to start a print the LEDs light up and Inkspace seems to think it is communicating but again no motion.

Now I am a little stuck. Software seemst to be loaded correctly, communication is happening but nothing is moving. Maybe something wrong with the shield? Seems unlikely, it is brand new.

Anyone have any thoughts?

Thanks!
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
RE: Having problems detecting the Arduino?: Checking things - colbrydi - 04-14-2017 01:40 AM

Forum Jump:


User(s) browsing this thread: 1 Guest(s)