JJRobots COMMUNITY
i need help - Printable Version

+- JJRobots COMMUNITY (http://forums.jjrobots.com)
+-- Forum: JJrobots (/forumdisplay.php?fid=1)
+--- Forum: Motorized Camera SLIDER (/forumdisplay.php?fid=47)
+--- Thread: i need help (/showthread.php?tid=2544)



i need help - adrik22 - 05-30-2020 12:53 AM

I can't get the pc in windows 10 to recognize the serial com port.

[Image: 2020-05-30-2-30-57.png]
I have disabled the antivirus

i follow this tutorial:
c) Compile and send the code to the DEVIA control board:

Open your Arduino IDE
Open the main code in \CameraSlider_vX_M0 \CameraSlider_vX_M0.ino
Connect your DEVIA board with the USB cable to the PC
Note: If this is the first time you connect an Arduino board to your PC maybe you might need to install the driver.
Select the board Arduino/Genuino ZERO (native USB port). In the TOOLS menu->board (You might need to install the “Arduino SAMD Boards (32-bits ARM Cortex-M0+)” libraries. Go to Tools->Board->Boards Manager… and install the “Arduino SAMD Boards (32-bits ARM Cortex-M0+)”
Select the serial port that appears on the tools->Serial port
Send the code to the board (UPLOAD button: Arrow pointing to the RIGHT)


I would have the complete kit to avoid problems and buy it configured, but it turns out that I had all the parts at home from a cnc machine.
I have tried on another macbook but selecting the com port is even more difficult ...

Arduino: 1.9.0-beta (Windows 10), Board: "Arduino Zero (Native USB Port)"

Error opening serial port 'COM1'. (Port not found)

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.


RE: i need help - JJrobots JP - 05-30-2020 09:12 AM

Looks like a drivers issue. I sometimes use the Arduino IDE online to solve it when I am working on another computer than mine. Try it: https://create.arduino.cc/


RE: i need help - MisterMaker - 05-30-2020 11:16 AM

This can also be a bad usb cable, I only use the blue arduino style versions.