JJRobots COMMUNITY
arm control servo does not move - Printable Version

+- JJRobots COMMUNITY (http://forums.jjrobots.com)
+-- Forum: JJrobots (/forumdisplay.php?fid=1)
+--- Forum: B-Robot (/forumdisplay.php?fid=2)
+--- Thread: arm control servo does not move (/showthread.php?tid=2135)



arm control servo does not move - luisleon - 07-06-2019 04:51 PM

The arm control servo does not move. I've gone through wiring and I've put in another servo. continue without moving. I have reviewed the voltage and it gives 5V in the power supply, 0.48 volts at rest and 0.69 volts when pressing the "SERVO" control. Can you help me please?


RE: arm control servo does not move - JJrobots JP - 07-08-2019 12:00 PM

The SIGNAL pin is sending a PWM so it is not easy to detect it with a multimeter, but it looks everything is fine on the electronics side. Try uploading the LASER POINTER arduino code and with its control APP, check if both servos outputs are working or not. That is a good way to narrow down the problem: https://www.jjrobots.com/remotely-controlled-laser-pointer/ Arduino CODE: http://www.jjrobots.com/wp-content/uploads/2015/09/LaserGUN.rar
NOTE: The control APP for the laser pointer is the same that the one for the B-robot


RE: arm control servo does not move - luisleon - 07-10-2019 11:36 AM

Thanks for the help. I followed your instructions and determined that the servo motor does not work. I have replaced it with another one and it is perfect, both with laser gun and with B-Robot.