JJRobots COMMUNITY
B Robot not Turning - Printable Version

+- JJRobots COMMUNITY (http://forums.jjrobots.com)
+-- Forum: JJrobots (/forumdisplay.php?fid=1)
+--- Forum: B-Robot (/forumdisplay.php?fid=2)
+--- Thread: B Robot not Turning (/showthread.php?tid=1503)



B Robot not Turning - juice - 01-09-2018 06:57 PM

I bought the electronics kit a little while ago and created my own base to fit the steppers I have on hand and mounted the electronics. I was able to get the robot to drive around and everything worked great except for the battery monitor (which is fine with me if it doesn't work).

Up until this morning. I was driving it around and showing it off when it tipped over, once on it's "feet" again it was able to drive forward and backwards just fine, but it's now unable to turn at all. Balances fine, moves fore and aft fine, but just doesn't turn.

Any thoughts?


RE: B Robot not Turning - JJrobots JP - 01-10-2018 11:32 AM

If you can move it forward/backwards that means the control commands are getting to the robot... Please check the IMU is in place and correctly oriented and, I do not know, replace the batteries? Actually, I do not know what to suggest here as this is a very weird problem!
If the motors response to the commands and the IMU is properly fitted, there should not be a problem when you are asking the motors to move in reverse to turn the robot.
Please double check the IMU and let us know how it goes.


RE: B Robot not Turning - juice - 01-10-2018 02:07 PM

Weird indeed, as was the solution. Tried charging my battery, nothing, replaced the IMU, nothing. Grabbed a buddies phone, worked perfectly. Reconnected with my old phone, still the same thing. Rebooted the phone and it worked perfectly again. It was the phone... No clue why or how, but it's fixed!


RE: B Robot not Turning - JJrobots JP - 01-10-2018 02:30 PM

(01-10-2018 02:07 PM)juice Wrote:  Weird indeed, as was the solution. Tried charging my battery, nothing, replaced the IMU, nothing. Grabbed a buddies phone, worked perfectly. Reconnected with my old phone, still the same thing. Rebooted the phone and it worked perfectly again. It was the phone... No clue why or how, but it's fixed!
Well. That was... I do not know how to name it. The smartphone┬┤s screen responded to vertical finger movements but not horizontal
We will add that to the troubleshooting: - Last option: reboot your smartphone! :-P