JJRobots COMMUNITY

Full Version: Unable to find an Eggbot on any serial port
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I know VERY LITTLE about programming. I'm trying to run my Sphere-O-Bot. I followed the directions to a T. I read about replacing the eggbot.py file. I did that.
I'm now getting, "Unable to find an Eggbot on any serial port."

As suggested by one post, I changed the eggbot_scanwin32.py file, but when I tried to save it, I got the following error message: "You do not have permission to open this file. See the owner of the file or an administrator to obtain permission."

I've seen others have had this problem, but the solutions are Greek to me. Can someone please explain step-by-step how I fix the problem? I'm trying to run it on a Windows 10.

Thanks.
EggArtist
Ok, I've uninstalled, reinstalled, made all the suggestions on the "Checking things" post: http://forums.jjrobots.com/thread-1199.html.

I'm getting this message:
Traceback (most recent call last):
File "eggbot.py", line 30, in <module>
import serial
ImportError: No module named serial

I tried item #8 and nothing happened. I tried #9 and my steps were different, but nothing changed.

I'm running on Windows 7 Professional and running Inkscape as an administrator.

Please help.
(07-17-2019 03:15 AM)figsonwheels Wrote: [ -> ]Ok, I've uninstalled, reinstalled, made all the suggestions on the "Checking things" post: http://forums.jjrobots.com/thread-1199.html.

I'm getting this message:
Traceback (most recent call last):
File "eggbot.py", line 30, in <module>
import serial
ImportError: No module named serial

I tried item #8 and nothing happened. I tried #9 and my steps were different, but nothing changed.

I'm running on Windows 7 Professional and running Inkscape as an administrator.

Please help.
Did you replace the eggbot.py file? That seems to be the source of the problem
Reference URL's