JJRobots COMMUNITY

Full Version: Error messages when sending code to board
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,

I recently purchased Brobot board and Arduino Leonardo including stepper robots drivers from JJrobots and trying to upload the code to the Leonardo board, when getting following error message:

Arduino: 1.6.12 (Windows 10), Board: "Arduino Leonardo"

C:\Robotics\arduino-1.6.12-windows\arduino-1.6.12\BROBOT\BROBOT.ino:8:19: warning: character constant too long for its type

<meta charset='utf-8'>

^

BROBOT:22: error: stray '\302' in program

<title>B-ROBOT/BROBOT.ino at master · jjrobots/B-ROBOT · GitHub</title>

^

BROBOT:22: error: stray '\267' in program

BROBOT:22: error: stray '\302' in program

BROBOT:22: error: stray '\267' in program

C:\Robotics\arduino-1.6.12-windows\arduino-1.6.12\BROBOT\BROBOT.ino:135:8: warning: missing terminating ' character

<!-- '"` --><!-- </textarea></xmp> --></option></form><form accept-charset="UTF-8" action="/jjrobots/B-ROBOT/search" class="js-site-search-form" data-scoped-search-url="/jjrobots/B-ROBOT/search" data-unscoped-search-url="/search" method="get"><div style="margin:0;padding:0;display:inline"><input name="utf8" type="hidden" value="&#x2713;" /></div>

^

BROBOT:135: error: missing terminating ' character

<!-- '"` --><!-- </textarea></xmp> --></option></form><form accept-charset="UTF-8" action="/jjrobots/B-ROBOT/search" class="js-site-search-form" data-scoped-search-url="/jjrobots/B-ROBOT/search" data-unscoped-search-url="/search" method="get"><div style="margin:0;padding:0;display:inline"><input name="utf8" type="hidden" value="&#x2713;" /></div>

^

C:\Robotics\arduino-1.6.12-windows\arduino-1.6.12\BROBOT\BROBOT.ino:392:126: warning: missing terminating " character

<a href="/jjrobots/B-ROBOT/commit/c492d9344b296eb755e6342c4ba7b1f1feffa595" class="message" data-pjax="true" title="New version

^

BROBOT:392: error: missing terminating " character

<a href="/jjrobots/B-ROBOT/commit/c492d9344b296eb755e6342c4ba7b1f1feffa595" class="message" data-pjax="true" title="New version

The full list of messages is much longer.


Can you advise what I need to change in order to upload the code to the board?

Thank you
It looks like this version of IDE has problem with the source code, try an older version like 1.6.8.
Good luck!
(10-17-2016 09:51 PM)jimmy Wrote: [ -> ]It looks like this version of IDE has problem with the source code, try an older version like 1.6.8.
Good luck!

getting the same error messages even using the older version of 1.6.8 or 1.6.6. Using the code version available on: https://github.com/jjrobots/B-ROBOT/tree/master/BROBOT
Jimmy is right. The problem is created by the IDE. Use the Arduino IDE 1.6.5, the one suggested in the B-robot Assembly guide. We have tested and compiled the code with that version. (actually, with the later versiond too: the warning messages are just warnings, the code should be compiled without issues) ;-)
milan_flash
Copy the whole file from the root directory, unzip and fill sketch BROBOT.ino. Do not copy it from the context menu "Save as ..." !!! In the latter case, the html code tags are added.
(10-18-2016 10:22 AM)KomX Wrote: [ -> ]milan_flash
Copy the whole file from the root directory, unzip and fill sketch BROBOT.ino. Do not copy it from the context menu "Save as ..." !!! In the latter case, the html code tags are added.
This works fine, thank you
I have a different upload error using
Arduino: 1.6.12 (Windows 10), Board: "Arduino Leonardo"

In file included from C:\User\Admin..\..\BROBOT|BROBOT.ino:51:0:

C:\Users\Admin..\..\libraries\MPU6050/JJ_MPU6050_DMP_6Axis.h:746:0: error: error: unterminated ardument list invoking macro "DEBUG_PRINTLN"

exit status 1
Error compiling for board Arduino Leonardo.

Need help, thanks.
Use the recommended Arduino IDE: 1.6.5 version
Did you install the b-robot libraries?
Reference URL's