Full Version: Motor type
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
i made a b robot (classic evo version with jjrobot brain)
and it is impossible to rise up without helping my robot.Undecided
It seems to be a motor problem;
i use a 3s 1300mah lipo with 2 steppers:NEMA17 Stepper Motor 40mm Long, 1.2A

200 steps per revolution (1.8 deg/step)
2 Phase bipolar 4 wires
Rated Voltage 2V DC
Rated Current 1.2A
Phase Resistance: 1.7 Ohm ± 10% (20º C)
Phase inductance: 4.5 mH ± 20% (1kHz 1 V rms)
Holding torque: 0.4 N.m Min.
Shaft diameter: 5mm / 0.188" (3/16")
Shaft length: 22mm
Motor depth: 40mm

with drivers A4988 setted to 0.8V
do you think with thoses my problem will be solved ?:
Datasheet(17HS8401,1.8A,78 oz-in or 4.8kg.cm holding torque,5mm diameter shaft):

thanks for help
(i joined a video of my problem)
another info:
i tried with a pair of 3d printer stepper which i have; thoses are :
Model: 17HS5425 Step angel: 1.8° Motor Length: 48 mm Shaft Length: 22 mm
Rate Voltage: 3.1 V Rate Current: 2.5 A Resistance: 1.25 Ω Phase Inductance: 1.8 mH
Static Moment: 48 N.cm
Positioning Torque: 2.8 N.cm
i didn't modify A4988 voltages
And the result is the same...
noise from motors when i try to rise up and after "balancing it by hands" a few moments, it is ok and the robot goes without problem.

Do i need to modify drivers voltage settings ??
another idea: power supply cable: i soldered power supply on the brain board; is it possible ?
thanks for help
Which microstep exposed hardware or software?
(10-11-2016 06:44 AM)KomX Wrote: [ -> ]Which microstep exposed hardware or software?
Hello Komx,

i am not sure to understand your question but thanks for your help !:
So, my drivers are two A4988
And i use the basic brobot code from jj robot so, microstep are setted to 1/16:
#define MICROSTEPPING 16   // 8 or 16 for 1/8 or 1/16 driver microstepping (default:16)

(if you need i can do a new video)
Reference URL's